Initial Site

Initial Site

Initial Site

Eclipse でSVNを使っていたら色々と大変だった話

  • モリヤ  2018/06/28 19:33
stressed-elderly-old-man-using-260nw-307307456

こんにちは
開発部のモリヤです。

お仕事で使っている環境が「Eclipse」+「SVN(Subversion)」になるのですが、先日コミットもチェックアウトもできなくなる現象に遭遇しました。。。

何とか解決はしたものの、調べても解決策がなかなか出てこなかったので、備忘として記事に残したいと思います。

直前に発生した問題

この現象が起こる前に、SVNプロジェクトで修正ファイルのコミットを行ったところ、「コミット(0%)」の表示で反応がなくなる現象が発生しました。
いくらまっても反応がないので、不安を感じながらもタスクマネージャーから強制的に終了を実行。

発生した現象

Eclipseを再起動後、再度コミットを試してみたところ、以下のようなエラーが発生しました。
01
ここまではまぁ、Eclipseを使ってれば何度かお目にかかる現象ではないかと思われます。
定番のクリーンアップを行い、再度コミットを試したところ、

 

『「コミット(0%)」の表示で反応がなくなる現象』が再度発生しました・・・

 

仕方がないのでリポジトリから再度チェックアウトを行おうと、下記画像のようにリポジトリURLを指定し「完了」を押したところ、

02

「ログ・メッセージ取得」の状態でレスポンスがなくなりました・・・

 

この時点で、様々な操作でレスポンスがなくなり、タスクマネージャーからの終了以外の手段がなくなりました。
・コミットを選択すると0%でレスポンスなし
・チーム → 更新を選択してもレスポンスなし
・上記画像の画面で、URLの参照ボタンを押下すると「保留中」でレスポンスなし

試してみたこと

・クリーンアップの実行 → 正常に終了するが現象改善せず
・eclipse.exe -cleanで起動 → 現象改善せず
・再チェックアウト → チェックアウトできないので試せず

現象からの考察

色々試してみて分かったのは以下のような点
・リポジトリURLが「http://」のものは今まで通り正常に動作
・リボジトリURLが「https://」のもので現象発生
・「TortoiseSVN」は問題なくチェックアウト可能
・いわゆる「反応なし」ではなく、Eclipse自体は動作しておりこちらの指示を保留している感じ?

特に「https://」だけ発生している状態から、SSL認証関連の問題な気がする?

改修までの流れ

その後も色々な記事を調べていたところ以下の記事を発見
eclipseでSVNErrorMessage.initCauseエラー(その2)

 

SVNコネクター」の切り替えについて解説があったため設定を、

03

SVNKit 1.7.11 ~」から、「SVNKit 1.3.8 ~」に変更してみたところ、
コミットや更新操作が動くようになった!
・・・んですが、代わりに色々とエラーが発生するようになり、結局動作せず。

 

しかしながら、SVNコネクターが関連していそうであることは分かったので、さっそくSubversive の本家サイトで最新のアップデートURLを確認し、「ヘルプ」→「新規ソフトウェアのインストール」から更新を行う。
04

 

更新後もう一度リポジトリからチェックアウトを行ったところ、「SSL認証について」確認のポップアップが表示されるようになり、この確認で「OK」を選択後、今までと同様にチェックアウトやコミットが動作するようになりました!
(Eclipse環境作り直しとかにならなくて本当によかったです。)


コメントをどうぞ

技術の記事

  1. mac-459196__340
    WordPressで出力内容が動的に変わる固定ページの<title>を変更
  2. startup-593296_960_720
    XAMPPのローカル環境を同じ社内LAN内の別PCからアクセスする方法
  3. 呪文
    実は俺、、、ホイミ使えます。
  4. printscreenFTHG9249_TP_V
    JSON形式でPOSTされたデータの受信方法